Neoficiální verze Xposed pro Android 5.1.x [Superalpha]

Neoficiální verze Xposed pro Android 5.1.x [Superalpha] 2015-5-15

S aktualizací Androidu na 5.0, a tedy přechodem na platformu ART, měli uživatelé populárního Xposed Frameworku na chvíli utrum. Jeho vývojář rovo89 však brzy přinesl verzi pro zařízení běžící na verzi Androidu 5.0. Vývoj však jde stále dopředu a s ním přicházejí i změny v samotné platformě ART. Kvůli těmto změnám se alpha verze XF stala nepoužitelnou pro uživatele se systémem ve verzi 5.1.x.

Framework-Xposed-Android-Lollipop-5.0-status-cover

V ten moment se pustil do práce vývojář vystupující pod přezdívkou romracer a přinesl neoficiální verzi Frameworku běžící na zařízeních s Androidem ve verzi 5.1. Na té však většina modulů nefungovala a způsobovala tzv. bootloopy. Nyní se však podařilo chyby a změny v ARTu objevit a Framework na jejich základě upravit. Největší podíl na tom má slovenský vývojář vystupující pod nickem C3C076, který stojí za populárním modulem GravityBox.

Neoficiální verze (superalpha) Xposed Frameworku je již nyní dostupná zde na xda a běžet by na ní měla bez problémů většina modulů, které běžely na alpha verzi pro Android 5.0. To však neznamená, že poběží všechny, je totiž hlavně na vývojářích, aby své moduly aktualizovali a přizpůsobili k fungování na Androidu 5.1.

Co se zatím stále nedaří vyřešit, jsou problémy s ROM používajícími rozhraní Touchwiz. Instalace superalpha verze se doporučuje spíše zkušenějším uživatelům, samozřejmě se také doporučuje vytvořit si zálohu systému. Připraveny jsou dvě verze, jedna pro systém ve verzi 5.1.0, druhá pro 5.1.1.

Michal Císařovský

Student ČZU v Praze, který se zajímá o vše kolem Androidu, především o aplikace. Rád zkouší nové komunitní ROM a především se neustále zabývá grafickými úpravami svého telefonu. Jeho nejoblíbenější modelovou řadou jsou Xperie. Mezi jeho další záliby patří fotografování, hudba a divadlo.